javascript - Naming convention for asynchronous getter - Stack Overflow

For synchronous getter functions, the naming convention is well-defined:var getFerby = function(){..ret

For synchronous getter functions, the naming convention is well-defined:

var getFerby = function(){
    ..
    return ferby;
};

However, if the ferby I want is not locally (synchronously) available, a mon method is to handle that situation with a callback:

/**
 * Asynchronously gets a ferby and passes it to the callback.
 *  
 *     Once the ferby is retrieved, these rules MUST be followed:
 *       1) Don't feed it after midnight.
 *       2) Don't give it water.
 *       3) Don't let it near bright light.  
 *
 * @param {ferbyCallback} callback - The callback function that expects a ferby.
 */
var fooFerby = function(callback){
    getFerbyLoader().load(function(ferby){
        callback(ferby);
    });
};

/**
 * The callback for the fooFerby function.
 *
 * @callback ferbyCallback
 * @param ferby The ferby
 */

What is a good naming convention for fooFerby so that I know by name that it expects a callback?

For synchronous getter functions, the naming convention is well-defined:

var getFerby = function(){
    ..
    return ferby;
};

However, if the ferby I want is not locally (synchronously) available, a mon method is to handle that situation with a callback:

/**
 * Asynchronously gets a ferby and passes it to the callback.
 *  
 *     Once the ferby is retrieved, these rules MUST be followed:
 *       1) Don't feed it after midnight.
 *       2) Don't give it water.
 *       3) Don't let it near bright light.  
 *
 * @param {ferbyCallback} callback - The callback function that expects a ferby.
 */
var fooFerby = function(callback){
    getFerbyLoader().load(function(ferby){
        callback(ferby);
    });
};

/**
 * The callback for the fooFerby function.
 *
 * @callback ferbyCallback
 * @param ferby The ferby
 */

What is a good naming convention for fooFerby so that I know by name that it expects a callback?

Share Improve this question asked Jun 11, 2013 at 14:43 Briguy37Briguy37 8,4223 gold badges35 silver badges53 bronze badges 2
  • i like getFerbyCB, _getFerby, cbGetFerby, or getFerbyAsync... – dandavis Commented Jun 11, 2013 at 15:14
  • @dandavis Thanks for the suggestions. Personally, I like the prefixes so you only have to look at the front of the name to get the general feel for the function, so _getFerby and cbGetFerby would be candidates for that. Looking at synonyms for get, some more candidates are acquireFerbie, grabFerby, obtainFerbie, procureFerbie, or (my personal favorite) fetchFerby. I was hoping for a semi-standardized naming convention for this. – Briguy37 Commented Jun 11, 2013 at 15:40
Add a ment  | 

2 Answers 2

Reset to default 5

I use the prefix "fetch", instead of "get" for asynchronous getters.

The idea is that if it is not locally available, you need to fetch it.

.NET uses BeginDoAction. I like the same approach in JavaScript. So in your case, the function would be beginGetFerby.

NodeJs takes the convention that most methods are asynchronous, and the synchronous methods have a 'Sync' suffix, e.g. doActionSync. You could do the opposite, and have an 'Async' suffix, so your function would be getFerbyAsync. I like that approach too.

发布者:admin,转转请注明出处:http://www.yc00.com/questions/1745612912a4636057.html

相关推荐

  • javascript - Naming convention for asynchronous getter - Stack Overflow

    For synchronous getter functions, the naming convention is well-defined:var getFerby = function(){..ret

    8小时前
    50

发表回复

评论列表(0条)

  • 暂无评论

联系我们

400-800-8888

在线咨询: QQ交谈

邮件:admin@example.com

工作时间:周一至周五,9:30-18:30,节假日休息

关注微信